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ABSTRACT 
Steganography is the art and science of invisible communication. This is accomplished through hiding information in other 

information, thus hiding the existence of the communicated information. The word steganography is derived from the Greek 

words “stegos” meaning “cover” and “grafia” meaning “writing” defining it as “covered writing”. In image steganography 

the information is hidden exclusively in images. Digital Image Steganography system allows an average user to securely 

transfer text messages by hiding them in a digital image file. A combination of Steganography and encryption algorithms 

provides a strong backbone for its security. Digital Image Steganography system features innovative techniques for hiding 

text in a digital image file or even using it as a key to the encryption. 
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1. INTRODUCTION 

Steganography is the art and science of writing 

hidden messages in such a way that no one apart from 

the sender and intended recipient even realizes there 

is a hidden message. By contrast, cryptography 

obscures the meaning of a message, but it does not 

conceal the fact that there is a message. Today, the 

term steganography includes the concealment of 

digital information within computer files. For 

example, the sender might start with an ordinary-

looking image file, and then adjust the color of every 

100th pixel to correspond to a letter in the alphabet -- 

a change so subtle that no one who isn't actively 

looking for it is likely to notice it. 

The word steganography is of Greek origin and 

means "covered, or hidden writing". Its ancient 

origins can be traced back to 440 BC. Herodotus 

mentions two examples of steganography in the 

histories of Herodotus. Demeratus sent a warning 

about a forthcoming attack to Greece by writing it on 

a wooden panel and covering it in wax. Wax tablets 

were in common use then as re-usable writing 

surfaces, sometimes used for shorthand. Another 

ancient example is that of Histiaeus, who shaved the 

head of his most trusted slave and tattooed a message 

on it. After his hair had grown the message was 

hidden. The purpose was to instigate a revolt against 

the Persians. Later, Johannes Trithemius's book 

Steganographia is a treatise on cryptography and 

steganography disguised as a grimoire. Generally, a 

steganographic message will appear to be something 

else: a picture, an article, a shopping list, or some 

other message. This apparent message is the cover 

text. For instance, a message may be hidden by using 

invisible ink between the visible lines of innocuous 

documents. The advantage of steganography over 

cryptography alone is that messages do not attract 

attention to themselves, to messengers, or to 

recipients. An unhidden coded message, no matter 

how unbreakable it is, will arouse suspicion and may 

in itself be incriminating, as in countries where 

encryption is illegal. Steganography used in 

electronic communication include steganographic 

coding inside of a transport layer, such as an MP3 

file, or a protocol, such as UDP.   

2. LITERATURE SURVEY 

We are living in an age of science. Communication 

has become major part of our daily life today. With 

the increasing communication traffic demand, data 

security has become very important field. [2] 

Lots of data security and data hiding algorithms have 

been developed in the last decade. In this project we 

are implementing a method of “Digital Stenography” 

for image data hiding [5].  

Digital Image Steganography system allows an 

average user to securely transfer text messages by 

hiding them in a digital image file. [6] 

 A combination of Steganography and encryption 

algorithms provides a strong backbone for its 

security. Digital Image Steganography system 

features innovative techniques for hiding text in a 

digital image file or even using it as a key to the 

encryption.[9] 

3. MAIN FUNCTIONALITIES 

Digital image steganography system is a stand-alone 

application that combines steganography and 

encryption to enhance the confidentiality of intended 

message. The user’s intended message is first 

encrypted to create unintelligible cipher text. Then 

the cipher text will be hidden within an image file in 

such a way as to minimize the perceived loss in 

quality. The recipient of the image is able to retrieve 

the hidden message back from the image with this 

system. 

3.1 Encoding 

In order to hide text in an image, the user must 

provide the text and a Target Image in which it is to 

be hidden. Optionally, users may enter or load a text 
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key. When a user key is not provided, a default key is 

used. To make choosing images easier, an image bar 

is provided for the user. The user may set the source 

directory, whose contents are displayed as thumbnails 

in the image bar located on the bottom panel of 

application. These thumbnails are automatically 

generated from the specified source directory. The 

user then selects a target image and loads it for use as 

the Target Image. The user may also open the Target 

Image by selecting Open Image under File menu. The 

user may enter the text to be embedded in several 

ways. He or she may type it directly into the text 

window, open a text file, or paste text from another 

application. The user may also open a text file by 

selecting Open Text under the File menu or use the 

Edit menu to paste from the clipboard. Loading a text 

key can be done from the Open Text Key selection on 

the Tools menu. When user has specified both the 

target image, and text body, Digital image 

steganography system is ready to hide the text body 

within the image. The user may then select Embed 

Text from the Tools menu. The key image will then 

be hashed into an appropriate Key Value. This value 

will be used for the encryption of the user’s plaintext 

to produce cipher text. The cipher text and key value 

will then be input into the steganography and bit 

placement algorithms, and the Output Image will be 

generated.  After the application has generated the 

image, the user may then inspect it by selecting the 

Image tab on the main panel. The user is then able to 

compare the encrypted target image with the original 

target image located on the right box of the main 

window. The user may wish to save the generated 

image by selecting Save Image or Save Image As… 

under File menu. 

3.2 Decoding 

In order to retrieve the hidden text from a source 

image, the user needs to provide a Source Image and 

any Keys used when the Source Image was 

generated. Loading the Source Image file is done 

similarly to the process of opening a Target Image. If 

the sender has used the default key, the recipient need 

not load any keys to the application. If a non-default 

key was used in text hiding process, the receiving 

party must have prearranged knowledge of the key 

for use in retrieving the text. This key could be text 

file or a key string. If the key is a text file, the user 

may load the key by selecting Open Text Key from 

the Tools menu. Lastly, the user may simply type in 

the key by activating the Text tab of the key panel 

and entering it. . After the Source Image and any 

required Keys are loaded into the application, the 

hidden text can be retrieved by selecting Extract Text 

from the Tools menu. The key will be hashed into an 

appropriate Key Value. This key value will be used to 

recover the hidden cipher text from the Source Image. 

The key will then be used for the decryption of the 

cipher text to produce plaintext. The plaintext will 

finally be displayed in the text box on the Text tab of 

the main panel. After the application has generated 

the text, the user may wish to save the generated text 

by selecting Save Text under the File menu. The 

application is not able to identify the presence of the 

hidden message in images until the actual decoding 

process is attempted, as the image files are virtually 

indistinguishable from normal images. 

4. STEGANOGRAPHIC TECHNIQUES 

 Modern Steganography entered the world in 1985 

with the advent of the Personal Computer applied to 

classical steganography problems.  Development 

following that was slow, but has since taken off, 

based upon the number of 'stego' programs available. 

• Concealing messages within the lowest bits                         

of noisy images or sound files.  

• Concealing data within encrypted data. The data 

to be concealed is first encrypted before being 

used to overwrite part of a much larger block of 

encrypted data. This technique works most 

effectively where the decrypted version of data 

being overwritten has no special meaning or use: 

some cryptosystems, especially those designed 

for file systems, add random looking padding 

bytes at the end of a cipher text so that its size 

cannot be used to figure out the size of the 

original plaintext. Examples of software that use 

this technique include Free OTFE and True 

Crypt.  

• Chaffing and winnowing  

• Invisible ink  

• Null ciphers  

• Concealed messages in tampered executable 

files, exploiting redundancy in the i 386 

instruction set.  

• Embedded pictures in video material (optionally 

played at slower or faster speed).  

5. DIFFERENT KINDS OF STEGANOGRAPHY: 

Almost all digital file formats can be used for 

steganography, but the formats that are more suitable 

are those with a high degree of redundancy. 

Redundancy can be defined as the bits of an object 

that provide accuracy far greater than  necessary  for 

the object’s use and display  without the alteration 

being done. Figure 5.1 shows the four main 

categories of file formats that can be used for 

steganography. 

    

                         Steganography     

                                         

 

 

 

     Text                     Audio/Video    Images 

 

Fig. 5.1 Categories  of Steganography 
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Hiding information in text is historically the most 

important method of steganography. An obvious 

method was to hide a secret message in every nth 

letter of every word of a text message. It is only since 

the beginning of the Internet and all the different 

digital file formats that is has decreased in 

importance. Text steganography using digital files is 

not used very often since text files have a very small 

amount of redundant data. 

Given the proliferation of digital images, especially 

on the Internet, and given the large amount of 

redundant bits present in the digital representation of 

an image, images are the most popular cover objects 

for steganography. To hide information in audio files 

similar techniques are used as for image files. One 

different technique unique to audio steganography is 

masking, which exploits the properties of the human 

ear to hide information unnoticeably. A faint, but 

audible, sound becomes inaudible in the presence of 

another louder audible sound. This property creates a 

channel in which to hide information. Although 

nearly equal to images in steganographic potential, 

the larger size of meaningful audio files makes them 

less popular to use than images. The term protocol 

steganography refers to the technique of embedding 

information within messages and network control 

protocols used in network transmission. In the layers 

of the OSI network model there exist covert channels 

where steganography can be used. An example of 

where information can be hidden is in the header of a 

TCP/IP packet in some fields that are either optional 

or are never used. 

6. IMAGE STEGANOGRAPHY ALGORITHM: 

The JPEG format is currently the most common 

format for storing image data. It is also supported by 

virtually all software applications that allow viewing 

and working with digital images. LSBs of After 

Embedding the image is processed again using a 

second pass. . Because chi-square attack is based on it 

6.1 Breaking Outguess 

The OutGuess steganographic algorithm was 

proposed by Neils Provos to counter the statistical chi-

square attack. In the first pass, similar to J-Steg, 

OutGuess embeds message. 

• Outguess Preserves the histogram of DCT 

coefficients exactly. 

• Outguess cannot be detected using the chi–square 

attack or its generalized versions.      

• Modifies LSBs of DCT coefficients at random 

locations. Corrects statistical deviation by 

modifying unused LSBs. 

• Distribution of DCT coefficients is preserved 

after embedding process.  

Outguess 

Proposed by Neils Provos in 2001 as a response to the 

statistical chi–square attach by Andreas Westfeldin 

1999. 

 

Main feature of outguess  

1. Outguess hides messages in JPEG files 

2. It embeds hides messages in bits in LSBs  of 

quantized DCT coefficients along a key–

dependent walk through the image.  

6.2 Algorithm for Encoding 

• The input is a Buffered Image object, which 

contains a Color Model and a matrix   

representing the image with pointers aimed at 

indices of the Color Model. The RGB values of 

the uncompressed input image are converted into 

three components: one luminance component 

and two chrominance components (YUV). The 

luminance component is considered more 

important. 

• The image is separated into 8x8 pixels Blocks 

starting from the upper left-hand corner. 

• The component signals for each 8x8 block are 

transformed into the frequency domain by using 

the two-dimensional discrete cosine transform 

(DCT). This transformation is similar to the two-

dimensional fast Fourier transformation.  

• While the coefficients closest to 0 are 

eliminated, the remaining coefficients are 

quantized using various degrees of accuracy. 

This can be modified by changing the 

quantization tables. The DC luminance 

coefficients are the most important and are 

quantized with the most accuracy. 

 
Fig.6.2.1 Block Diagram of Algorithm 

6.3 Algorithm for Decoding 

The decoding scheme is much simpler than encoding. 

The averages of the luminance of the 8x8 blocks just 

need to be calculated and converted back to bits. 

Basically what we exactly do in decoding process is:- 

• The user needs to provide a Source Image and 

any Keys used when the Source Image was 

generated.   

• If a non-default key was used in text hiding 

process, the receiving party must have 

prearranged knowledge of the key for use in 

retrieving the text. 
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• After the Source Image and any required Keys 

are loaded into the application, the hidden text 

can be retrieved by selecting Extract Text from 

the Tools menu. 

  7. CONCLUSIONS AND FUTURE  

    DEVELOPMENTS 

7.1 Future Development 

The application is primarily intended to be used to 

inconspicuously hide confidential and proprietary 

information by anyone seeking to hide information. 

This software has an advantage over other 

information security systems because the hidden texts 

are in the form of image, which are not obvious text 

information carriers. 

Because of its user-friendly interface, the application 

can also be used by anyone who wants to securely 

transmit private information. The main advantage of 

this program for individuals is that they do not have 

to have any knowledge about steganography or 

encryption. The visual way to encode the text, plus 

the visual key makes it easy for average users to 

navigate within the program. 

Digital Image Steganography system allows an 

average user to securely transfer text messages by 

hiding them in a digital image file. A combination of 

Steganography and encryption algorithms provides a 

strong backbone for its security. Digital Image 

Steganography system features innovative techniques 

for hiding text in a digital image file or even using it 

as a key to the encryption. 

Digital Image Steganography system allows a user to 

securely transfer a text message by hiding it in a 

digital image file. 128 bit AES encryption is used to 

protect the content of the text message even if its 

presence were to be detected. Currently, no methods 

are known for breaking this kind of encryption within 

a reasonable period of time (i.e., a couple of years). 

Additionally, compression is used to maximize the 

space available in an image.  

To send a message, a source text, an image in which 

the text should be embedded, and a key are needed. 

The key is used to aid in encryption and to decide 

where the information should be hidden in the image. 

A short text can be used as a key.  

7.2 Conclusions  

The meaning of Steganography is hiding information 

and the related technologies. There is a principal 

difference between Steganography and Encryption; 

however they can meet at some points too. They can 

be applied together, i.e. encrypted information can be 

hidden in addition. To hide something a covering 

medium is always needed (Picture, sound track, text 

or even the structure of a file system, etc.).  The 

covering medium must be redundant; otherwise the 

hidden information could be detected easily. The 

technology of hiding should match the nature of the 

medium.  The hidden information should not be lost, 

if the carrying medium is edited, modified, formatted, 

re-sized, compressed or printed.  That’s a difficult 

task to realize. It’s an expectation as well, that the 

fact of hidden information should be impossible to 

detect by other then the addressee.  On the other hand 

security services should have methods to detect such 

information. At least its existence.  Realizing a wood 

trade-off there are different technologies. Nowadays 

the most popular application of Steganography is 

hiding copy rights and other commercial information.  

Such kind of hidden information is known as e-

watermark.  The e-watermark is not always invisible. 

There are cases when it is made deliberately 

strikingly visible e.g. in case of trial versions of 

software. 
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